Menu

Tabellenblattname mit Zelle verknüpfen?

berna

Mitglied seit
07.07.2005
Beiträge: 206
Hilfreich: 0

Hallo allerseits,

ich habe eine Mappe mit xx Tabellenblättern und möchte auf einer zusammenfassenden Seite die Ergebnisse der einzelnen Seiten auflisten. In Spalte A sollen untereinander die Namen der einzelnen Tabellenblätter aufgelistet werden.
Weiß jemand wie das geht? Möchte mir auch jemand helfen???

Ich wäre euch seeehr dankbar!

LG
berna

Dieser Beitrag wurde 0 mal als hilfreich markiert.

zzx

Mitglied seit
30.10.2006
Beiträge: 312
Hilfreich: 0

Hallo,

ich gehe mal davon aus dass du eine Excel-Version ab XL97 meinst.

Da gibt es ohne VBA folgende Möglichkeit:

Zunächst einen Name definieren über Menü Einfügen - Name

Im Feld 'Namen in der Arbeitsmappe:' eingeben: x (Buchstabe x eingeben)

Und bei bezieht sich auf:

[code:1:8b2fe8c477]=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())[/code:1:8b2fe8c477]

Dann in der Übersichtsseite in irgendeine Zelle die folgende Formel:

[code:1:8b2fe8c477]=WENN(ZEILE(A1)>ANZAHL2(x);"";TEIL(INDEX(x;ZEILE(A1));FINDEN("]";INDEX(x;ZEILE(A1)))+1;31))[/code:1:8b2fe8c477]

Diese Formel kopierst du soweit wie notwendig nach unten.

Gruss
zzx

Dieser Beitrag wurde 0 mal als hilfreich markiert.

Marika

Mitglied seit
03.12.2002
Beiträge: 74
Hilfreich: 0

moin moin,

vielleicht mit´m Makro ??

Public Sub TabellenblätterNamenAuslesen()
Dim Blatt As Object
Application.DisplayAlerts = False
On Error Resume Next
Worksheets.Add = "Übersicht"
Worksheets("Übersicht&quot.Activate
Range("A1&quot.Value = "Namen der Tabellenblätter"
Range("A2&quot.Select
For Each Blatt In Sheets
If Blatt.Name <> ActiveSheet.Name Then
ActiveCell.Value = Blatt.Name
ActiveCell.Offset(1, 0).Select
End If
Next Blatt
Application.ScreenUpdating = True
End Sub

o.k. ??

cu Marika

Ein Freund ist ein Mensch, der Dich mag, obwohl er Dich kennt. [img:0c9ffa1d10]http://www.smilies-world.de/smilies/smilies_Picture/winkende/4.gif[/img:0c9ffa1d10]

Dieser Beitrag wurde 0 mal als hilfreich markiert.

Marika

Mitglied seit
03.12.2002
Beiträge: 74
Hilfreich: 0

moin moin,

vielleicht vorher noch sortieren ??

Sub SortierungBlätter()

Dim i As Integer
Dim j As Integer

For i = 1 To Sheets.Count
For j = 1 To Sheets.Count - 1
If UCase$(Sheets(j).Name) > UCase$(Sheets(j + 1).Name) Then
Sheets(j).Move after:=Sheets(j + 1)
End If
Next j
Next i

End Sub

o.k. ??

cu Marika

Ein Freund ist ein Mensch, der Dich mag, obwohl er Dich kennt. [img:0c9ffa1d10]http://www.smilies-world.de/smilies/smilies_Picture/winkende/4.gif[/img:0c9ffa1d10]

Dieser Beitrag wurde 0 mal als hilfreich markiert.
Hinweis: Sie müssen sich einloggen um antworten zu können. Noch kein Login? Hier registrieren.